Monday, 7 October 2013

Keyboard Error, Press F1 - IBM 5160 Part 3

When I last wrote about the IBM5160 I was in the process of stripping down and rebuilding, it turned into a brief history of disk drives, mainly because I didn't have an XT compatible keyboard. The system was sitting there showing keyboard error (301) and requesting F1 be pressed to continue.
Although it had the same 5 pin DIN connector, the XT had a different keyboard protocol to the AT standard, which is still in use today, only the connector has changed from the 5 pin din on the AT to the 6 pin mini din connector on the PS/2.
Both protocols (the nice, elegant XT one and the later overcomplicated AT one) required only two pins, a clock and a data pin. I had started to design a simple converter using an 8 pin AT Tiny microcontroller. When looking for further information on the protocols, I came across this thread on the Vintage Computer Forum. It appears I'm not the only one in this predicament, and someone had already designed such a device, using an 8 pin PIC. Rather than reinvent this particular wheel, I programmed the firmware supplied by Chuck(G) in this post into a PIC12F629 and built the circuit on breadboard. It worked first time. Further information and schematics here.
I had removed all the drives and most of the cards and had only just started putting bits back together, so with no boot device available, the 5160 loads Microsoft BASIC from ROM.
A quick bit of testing and the keyboard is working fine, so I built it up into a little box.
A 5 pin cable plugs into the XT, and there are two options for a keyboard to plug in.
Either an older AT style keyboard.
Or a recent PS/2 keyboard.
Adding the drives back and trying a DOS disk, booted up into DOS and away it goes.
I also had a try with the hard drives. Initially they were reporting problems, but I found an old copy of Norton Disk Doctor and set it going.
It didn't seem to like the CGA card, so I tried another and got the same result. Must not be compatible, so I dug out an 8 bit compatible VGA card and tried again.
That sorted out the problems and started booted into DOS 6.22. However, it then started some type of 'Power Menu' which wouldn't do anything without a password. I tried the usual candidates, but didn't manage to guess it. Easy enough to bypass though. I need to copy off things like software for the 'AST MegaPlus II' card, and then go for a clean install of DOS and all my usual software. Drives of that vintage are rather noisy and delicate, so I'll will probably mothball these as they are and look at using something like a compact flash card.
The power supply is likewise rather noisy, I've started stripping that down, with a plan to potentially replace the fan with a quieter one. I've noticed a couple of X type mains filter capacitors which have a habit of exploding, BBC model B's suffer from that a lot. I'll replace those, give it a good clean and check out the rest of the capacitors before putting it back together.
There is also a bit of a bodge where one of the disk drive power cables has been cut and and extra power cabled spliced in and the joints wrapped in cloth tape. I'll probably try to undo that mod and return it to its former condition.
Read more in the next article....