Friday, 17 March 2017

Spanish Spectrum+ 128K Repair

A while ago I ended up with a broken board from a Spanish Spectrum+ 128K. This was the original case, which the owner wanted converted into a USB keyboard. The first obvious issue from outside is that the large heatsink which give the 'toastrack' it's nickname is missing.
The first obvious problem inside is the ULA, which was inserted upside down, I corrected that before I powered it on.
Since the heatsink was missing, I borrowed a random bit of metal and bolted the loose 7805 onto it.
On powering it up I got a faint signal on the RF, I could just about make out the copyright notice. (this is actually a later picture after it was cleared up a bit, it was a worse than this before)
Since there were some signs of life, I replaced that regulator with a switch mode version, so no more need for the large heatsink (which I didn't have anyway).
With that replaced I could get on with the rest of the testing. The 12V rail wasn't very good when I measured it, and with the video problems, it seemed a good idea to recap this board. Not something I usually do out of course.
I also replaced the switching transistors, may as well, they have a tendency to fail on Spectrums.
That didn't make any difference to the picture, but at least the supply rails were now stable. I thought about retuning the modulator, but when I opened the case, I found the ferrite core used to tune the frequency was broken.
I could replace that, but easier and more useful to convert that to a composite video output. There is a composite lunimance signal on the RGB port, but no composite video. I did try RGB output, but I was getting odd signals there as well. I didn't have a suitable lead as the Spanish 128K, the UK 128K and the later +2A etc. all had different RGB pinouts.
Checking the signal going into the modulator was a bit confusing. It looked like a sort of composite video signal, but inverted. The noise on the signal is the audio subcarrier, I'll remove that later.
This is from a working 128K.
I tried swapping out the TEA2000 (the colour encoder) and the ULA (for a later Amstrad version from a Grey +2), but was still getting incorrect signals.
The composite video which feeds the modulator comes from a three transistor amplifier circuit.
Checking those parts, all three transistors were working correctly and fitted the right way around (a common fault on +2 Spectrums is transistors inserted backwards). The only schematic I could find was for the later UK version, but it was mostly the same.
Tracing it back, the signal looked a lot better at the TEA2000 output. I tried removing and testing various parts of that circuit, but it just wasn't giving the right output. Eventually I decided the easiest thing to do to generate a composite video output with a simple single transistor buffer. I also removed the capacitor on the bottom of the page which links the audio signal into the composite video which gets rid of the noise on the signal.
I managed to fit the replacement circuit into the board using the existing pads, and fed the signal direct to the composite video output jack on the modulator. There is now only a single transistor, mounted the wrong way around where TR10 was.
I originally had this fed via a DC blocking capacitor, but I was getting a bit of 'wavyness' on the output, which wasn't there on the other side.
Since the output seemed to be biased around 5V by the TEA2000, I used a 5.1V zener diode, reverse biased instead of the 1N4148 originally used in the base drive of the transistor.
The signal from this was a lot more like it, and at last I had decent video output from this machine. Looks good on the LCD monitor.
The Spanish mode has some interesting quirks, it is one that requires you to type keywords in full, and has an interesting way of pointing out errors with a little bug character.
Had to be done.
There is also a bar which indicates mode (uppercase, lower case, extended etc.) which is always at the bottom of the screen, rather than inverse K/E etc.
The Spanish ROM does not have the menu like the UK 128K. Not sure if it's the official way, but typing USR 0 takes you to 48K mode.
I did try switching the ROM for the UK Spectrum+ 128K ROM, and it seemed to run OK,
I want to keep this as a Spanish 128K. so back to the ROM with the 'DERBY SP' label on it.
No startup menu on this one, just the 1985 copyright screen.
Trying out or the ZX Spectrum Diagnsotics V0.33, it didn't detect the Spanish ROM, it's CRC may not be in the table, but all the other diagnostics tests passed
The colour bar looks OK, not perfect, but you're not going to get that much better with composite video anyway. The sound tests show the usual differences in level from the default beep to the AY chip, I need to adjust these at some point.
I ran this on a soak test for a while with only the ULA getting warm, so I fitted that with a heatsink. The board seems to be running OK, I didn't have the original case (that was back with it's original owner), so I just had the board.
The case of a 48K Spectrum+ should provide a suitable replacement. They are very similar, just a few connectors in different places.
The large case accommodates the same board which fits the original rubber key Spectrums, but there is space, for the larger 128K board. Note they still have the reset switch on wires. The 48K board in the above photo should have have a wired reset switch, but it was missing.
The power and edge connector were fine, but I had to widen the slots for the modulator connector and the RGB socket (the old ear socket).
I drilled two holes on the side for the new location of the ear and mic sockets.
The Spanish 128K models had '128K' in white next to the rainbow stripes, so I had to add that.
Some of the keycaps are different on the Spanish models, so I may try to get hold of a Spanish 48K Spectrum+ with a more suitable keyboard. Can you tell which one is mine, and which is an original Spanish Spectrum 128K?
Time for some testing.
So far, so good.
All the software I have tested seems to run fine.
Games all seem to be loading, both 48K and 128K versions.
It's hard work having to test all these things.
Finally time for another go of the newly released Pilot Attack from Misfit.

If you want to support this blog, you can donate via Patreon or Paypal, or buy something from my store.